Evinrude VRO bogging

Just Purchased this engine.
1989 Evinrude 70 VRO
Splashed this engine for the first time yesterday, started up fine. Ran at about 3000rpm for 15 mins (rough water) turned to go with the waves and pushed it up to 4000rpm engine sputtered and then cut back to about 1000rpm. Had to limp back into launch at this very low rpm. When throttle was push forward, engine would just bog down. I think the (S.L.O.W.) Kicked in. Before I start the costly repairs thought maybe you could advise.
Cool Site,
Thanks

Glenn

 

Glenn, 

Either you have a real problem and the engine is protecting itself or the SLOW system is malfunctioning. I'd take it in - if you have a problem it would be expensive if you keep running it. Not much info. in your request. Does the buzzer sound during all this?? It should be giving a coded sound when this happens. Take it in and have it looked at. 

Randy

 

 

Please submit whatever questions you have to IHRTechTalk@yahoo.com.  All questions and answers selected will be displayed on this page as they come in.  Note: though all boaters are welcome, priority may be given to I.H.R. members.  Randy can not be held responsible for any advice given.  Though his information and expertise is second to none, he has no control over what you do with your boat.  It is up to you to boat safely and act responsibly, and his advice is only to be used as a guidance for your high performance boat/motor of which you are the one responsible for the risks involved.

Thanks,
Mark C.

 

[ Home l About I.H.R. l History l Models l Registry l Members' Pictures l Feature Article l Tech Talk ]
[ Literature l Events l Top Guns l Guest Boat l Classifieds l Video Gallery l Racing Corner ]
[ Prop Slippage Program l Animated Videos l Screen Savers l HIN Decoder l Links l Contact Mark ]