Engine Idle Trouble

I currently own an '88 175 Mariner that has problems idling below 1000 rpms.  It also has a slight recharging problem but not significant.  When at idle it hesitates and eventually dies unless it is revved up.  Also the longer the motor is run the worse the symptoms get, eventually to the point that restarting becomes a major problem.  I was thinking that it was probably the stator but wasn't sure.  Any advice would be greatly appreciated.  Thank you for your time.

 

Coupe 427, 

Not knowing if this is on EFI or a carb 175, I'll give you some scenarios. If it is carbed, I think you have a needle/seat assembly that is leaking by at the low speeds. Some new ones with proper set floats would probably cure the problem. Usually a stator is bad all the time not after an extended idle. If it is an EFI have the TPI (Throttle Position sensor) checked. If bad or out of sync, it could cause the problem.  

Randy

 

 

Please submit whatever questions you have to IHRTechTalk@yahoo.com.  All questions and answers selected will be displayed on this page as they come in.  Note: though all boaters are welcome, priority may be given to I.H.R. members.  Randy can not be held responsible for any advice given.  Though his information and expertise is second to none, he has no control over what you do with your boat.  It is up to you to boat safely and act responsibly, and his advice is only to be used as a guidance for your high performance boat/motor of which you are the one responsible for the risks involved.

Thanks,
Mark C.

 

[ Home l About I.H.R. l History l Models l Registry l Members' Pictures l Feature Article l Tech Talk ]
[ Literature l Events l Top Guns l Guest Boat l Classifieds l Video Gallery l Racing Corner ]
[ Prop Slippage Program l Animated Videos l Screen Savers l HIN Decoder l Links l Contact Mark ]