Voo-doo Help

I just bought a 1987 voodoo and have a 1992 40 hp Johnson long shaft 20 inches. I was disappointed - I just took it out and got to 14 mph and the boat revved to 6000 rpm and nothing. My friend said the lower unit is coming out of the water. What’s wrong with this set up? The motor is in the lowest spot too. Ok, the other thing is I installed a fish finder for the depth and speed.  I installed the transducer and speed sensor on the pad at the bottom of the boat. Please help.
mike

 

Get the speed sensor and transducer off of the boat. Run a cupped 15" - 17" prop and try it again.

Randy

 

 

Please submit whatever questions you have to IHRTechTalk@yahoo.com.  All questions and answers selected will be displayed on this page as they come in.  Note: though all boaters are welcome, priority may be given to I.H.R. members.  Randy can not be held responsible for any advice given.  Though his information and expertise is second to none, he has no control over what you do with your boat.  It is up to you to boat safely and act responsibly, and his advice is only to be used as a guidance for your high performance boat/motor of which you are the one responsible for the risks involved.

Thanks,
Mark C.

 

[ Home l About I.H.R. l History l Models l Registry l Members' Pictures l Feature Article l Tech Talk ]
[ Literature l Events l Top Guns l Guest Boat l Classifieds l Video Gallery l Racing Corner ]
[ Prop Slippage Program l Animated Videos l Screen Savers l HIN Decoder l Links l Contact Mark ]